BMWSportTouring BMWST DB
Previous Thread
Next Thread
Print Thread
Page 1 of 4 1 2 3 4
#1001056 - 11/17/17 10:40 AM 2017 RT Heated Seat not working  
Joined: Jun 2017
Posts: 13
skyking1 Offline
Newer Member
skyking1  Offline
Newer Member

Joined: Jun 2017
Posts: 13
South Carolina
Hey Folks,
I have had my 17' RT for a couple of months....and having a BIG BIG TIME with it.

I turned the heated seats and hand grips on the other evening when it got cool.
Hand grips on high are hot hot hot, back it down to 1 and very comfortable.

I don't think the heated seat is working, the light on the dash shows its on, and the wonder wheel has it on high.....butt feels nothing.
Just wondering if I'm doing something wrong? I did took the seat off to see if it was plugged in and it was. I turned the back seat heat on and the lights came on, not sure if it got hot.

I hate to look like an idiot when I go by the dealer....and he flips a switch.

and does the seat get as hot as the hand grips?

Thanks for any info.

#1001058 - 11/17/17 12:04 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Sep 2005
Posts: 6,786
TEWKS Online
Member
TEWKS  Online
Member

Joined: Sep 2005
Posts: 6,786
Tewksbury, MA.
Could try to unplug/plug it back in. Never know. dontknow Wouldn't worry about the dealer, if a simple fix and you're happy, then they are happy. thumbsup

Pat


"If at first you don't succeed, keep on sucking till you do succeed" Curly Howard
#1001062 - 11/17/17 02:13 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Nov 2002
Posts: 4,782
AndyS Offline
Member
AndyS  Offline
Member

Joined: Nov 2002
Posts: 4,782
Somerset, Great Britain.
It should be noted that I too find it difficult to detect heat from the OEM riders heated seat, however, it is there (just). I know several other folk who have said the same thing.
It would be worth you just popping the seat off and check the lead is correctly plugged in.

#1001066 - 11/17/17 02:25 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Oct 2000
Posts: 1,028
Paul De Offline
Member
Paul De  Offline
Member

Joined: Oct 2000
Posts: 1,028
Milwaukee Wisconsin, USA
If your display shows an orange seat then you got it switched on correctly, no other hidden switch for the rider seat. The passenger seat switch is on it's left side (by the key latch) and is an old school toggle. Also you might also check if passenger seat is heating. Like Pat said check the connector(s). Yes, the OEM seat seems to have the element embedded in the foam so it takes a while to notice the warmth. If one or both are still dead then off to the dealer for a look over.


If the good old days were so damn good, why did we bother to invent modern times?

Most missed bike: Bultaco Sherpa T 326
#1001076 - 11/17/17 03:48 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Jan 2006
Posts: 1,730
realshelby Online
Member
realshelby  Online
Member

Joined: Jan 2006
Posts: 1,730
Houston, Tx
There was a TSB early on for these. Seems some early models got too hot. Maybe there is a way the dealer can adjust output?

#1001084 - 11/17/17 04:38 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Sep 2004
Posts: 4,453
Bill_Walker Offline
Member
Bill_Walker  Offline
Member

Joined: Sep 2004
Posts: 4,453
San Marcos, CA USA
I used mine for the first time recently. It probably took 10-15 minutes before I noticed any heat.


"Dry-Town" Crew, San Diego
'15 R1200RT
'12 Kawasaki KLX250S
'04 R1150RT (gone)
'02 Suzuki V-Strom (gone)
#1001088 - 11/17/17 04:49 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Jun 2017
Posts: 13
skyking1 Offline
Newer Member
skyking1  Offline
Newer Member

Joined: Jun 2017
Posts: 13
South Carolina
Thanks for the info..

I unplugged and plugged it back up under the seat. Looked for anything that was lose or unplugged and did not see anything.

Turned it on HI and rode about 18 miles home....and nothing.

I was expecting to heat up about like my truck seat does.

Got a appt. with service department in the morning to check it out.

Thanks

#1001094 - 11/17/17 07:09 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Oct 2000
Posts: 1,028
Paul De Offline
Member
Paul De  Offline
Member

Joined: Oct 2000
Posts: 1,028
Milwaukee Wisconsin, USA
Originally Posted by skyking1
Thanks for the info..

I unplugged and plugged it back up under the seat. Looked for anything that was lose or unplugged and did not see anything.

Turned it on HI and rode about 18 miles home....and nothing.

I was expecting to heat up about like my truck seat does.

Got a appt. with service department in the morning to check it out.

Thanks

Hope it is a simple 15 minutes and fixed and not a dud seat. For sure in 18 miles you would notice the warmth. Since I bought my RT I swapped my OEM saddle out for Sargent seat and the heating element is just under the vinyl cover so you feel the heat right away. On high it will make you butt burn hotter than the morning after a 10 habanero chili dinner.


If the good old days were so damn good, why did we bother to invent modern times?

Most missed bike: Bultaco Sherpa T 326
#1001095 - 11/17/17 07:14 PM Re: 2017 RT Heated Seat not working [Re: Paul De]  
Joined: Jun 2017
Posts: 13
skyking1 Offline
Newer Member
skyking1  Offline
Newer Member

Joined: Jun 2017
Posts: 13
South Carolina
I hope a simple fix, I will post back after the visit to the dealer.

#1001097 - 11/17/17 07:28 PM Re: 2017 RT Heated Seat not working [Re: skyking1]  
Joined: Oct 2010
Posts: 45
roadriderg Offline
Newer Member
roadriderg  Offline
Newer Member

Joined: Oct 2010
Posts: 45
Huntington beach Ca
I hope you get it fixed with no problem . Only thing i know that would shut them down would be low battery power and this would show up on dash as the red battery icon. Maybe there is some computer setup that has gone awry.
But the chance of both the rider and passenger seat being bad is very remote.

Last edited by roadriderg; 11/17/17 07:34 PM.

Gary
Page 1 of 4 1 2 3 4

Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.009s Queries: 14 (0.002s) Memory: 2.8022 MB (Peak: 2.9871 MB) Zlib enabled. Server Time: 2017-12-14 19:08:08 UTC